Author Topic: Black screen with mouse cursor on Cinnamon Hardware accelerated  (Read 618 times)

0 Members and 1 Guest are viewing this topic.

Offline Ghi102

  • Neuling
  • *
  • Posts: 15
  • Branch: Stable
  • Desktop: Latest Cinnamon
  • GPU Card: Integrated AMD Radeon R5 (laptop)- GTX970 (desktop)
  • GPU driver: nonfree
  • Kernel: 4.1.19
  • Skill: Intermediate
I've been trying to make Cinnamon work for a couple of hours now. I can make the Software Rendering Cinnamon work just fine (it's what I'm using right now), but whenever I try to use the hardware accelerated version of Cinnamon, all I get is a black screen with my mouse cursor. I'm using the nvidia nonfree driver. I've seen this question pop up a couple of times but none of the solutions I tried worked. A post suggested it might have something to do with cogl and cinnamon badly interacting with each other, but I could not manage to downgrade cogl.

Offline annoyingduck

  • Neuling
  • *
  • Posts: 5
  • I'm new. Be nice!
  • Desktop: XFCE
  • Skill: Intermediate
This happened on one of my machines with an older Nvidia card.  What I did was on the grub screen highlight the main boot option (not rendering one), press e to edit the boot option. Find the line that starts with "Linux" and ends with "quiet splash", then delete the words "quiet splash" and just add "3", press F10 to boot with this option.  You'll be in terminal only mode (single user).  Enter your user name then password and run the command
Code: [Select]
sudo pacman -Syy then run
Code: [Select]
sudo mhwd -a pci nonfree 0300 to install the proprietary driver. Then sudo reboot.  This worked for me, hopefully for you.