Author Topic: jwm: startx not working  (Read 1032 times)

0 Members and 1 Guest are viewing this topic.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
jwm: startx not working
« on: 18. March 2016, 12:55:31 »
I'm trying to assist Holmes a little with the re-animation of his beautiful jwm-edition.
To everything I know the profile and settings look fine for the new tools. However the graphical session will not start. When using a DM you will be thrown back to the login screen or with startx you get:



So, no obvious errors.
no .xsession-errors

Here's the last bit of /var/log/Xorg.0.log



I can't see anything there that would tell me more ???

.xinitrc:
Code: [Select]
#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#
#
## Ensure that the D-Bus Communication System is running properly to fix
## File management, authentication, and other essential system processes (I)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
  eval "$(dbus-launch --sh-syntax --exit-with-session)"
fi

exec /usr/bin/jwm

Now the weird thing:
When I login as root and use the default /etc/X11/xinit/xinitrc, copied over to /root/.xinitrc with only the last lines replaced with exec /usr/bin/jwm I get a flawless jwm session (with the default settings of course ... :P )

Ideas anyone?
here's the profile: https://github.com/manjaro/manjaro-tools-iso-profiles/tree/master/community/jwm
and desktop-settings: https://github.com/manjaro/desktop-settings/tree/master/community/jwm
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: jwm: startx not working
« Reply #1 on: 18. March 2016, 13:14:38 »
Ok. Well, after all it seems to be obvious that there is one or the problem with Holmes' jwm config. C:-)
I have now copied the .jwmrc and .jwm/ to /root and from that moment on the session will not start ...
He will just have to fix that ;)
« Last Edit: 18. March 2016, 14:22:57 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: jwm: startx not working
« Reply #2 on: 18. March 2016, 13:47:29 »
Holmes!

When I comment out in .jwmrc
Code: [Select]
<!-- <Include>$HOME/.jwm/tray</Include> -->The session starts, just with no background and conky with the default conkyrc
The menu is working ;) ;D
So: The fatal error seems to be in ~/.jwm/tray and seems there are also some errors still in ~/.jwm/start
At least I think now you have something to work from! ;)
Good luck! The glade is close!! 8)
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Holmes

  • Mirror Support Team
  • ***
  • Posts: 2039
  • Brazilian and Hispanic Support Team
    • Manjaro Brasil
  • Branch: Stable
  • Desktop: Manjaro XFCE
  • GPU Card: Mobile Intel (R) 945
  • GPU driver: Non-free
  • Kernel: kernellinux
  • Skill: Novice
Re: jwm: startx not working
« Reply #3 on: 18. March 2016, 14:16:34 »
hi @oberon,
strange all this, i see what's going on. i'm creating the iso with the new structure!

vlw fwi, Holmes :)


==> Manjaro Brasil I Manjaro Hispano
==> IRC Manjaro Brasil: #manjaro-br I IRC Manjaro Hispano: #manjaro-es

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: jwm: startx not working
« Reply #4 on: 18. March 2016, 14:18:22 »
The tray is very much customized. Can you to make it easy and post the tray config? :)
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: jwm: startx not working
« Reply #5 on: 18. March 2016, 14:25:15 »
@eugen-b , please look here: https://github.com/manjaro/desktop-settings/tree/master/community/jwm/skel/.jwm
Something must be wrong with ~/.jwm/start file, too, as conky with the intended config and nitrogen --restore are obviously not working.
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: jwm: startx not working
« Reply #6 on: 18. March 2016, 14:29:57 »
Since I have corrected some things
https://github.com/manjaro/desktop-settings/commit/c26774d8cf0e2f3a2e0db857d9895703c0305ec7
and
https://github.com/manjaro/desktop-settings/commit/9ec82234fc50510b4b7a9fd7841114fac7ea7a2d
jwm -p doesn't throw any errors. So for jwm the syntax seems to be fine. It's the execution of the actual commands - or what jwm through the config makes them in the end ;) that seems to fail ... if you see what I mean ;) ;D
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Holmes

  • Mirror Support Team
  • ***
  • Posts: 2039
  • Brazilian and Hispanic Support Team
    • Manjaro Brasil
  • Branch: Stable
  • Desktop: Manjaro XFCE
  • GPU Card: Mobile Intel (R) 945
  • GPU driver: Non-free
  • Kernel: kernellinux
  • Skill: Novice
Re: jwm: startx not working
« Reply #7 on: 18. March 2016, 14:30:17 »
i finished doing the iso is so is in the login manager.
the strange thing is: the iso works perfectly with the old structure and the new gives error.
because?

vlw fwi, Holmes :)


==> Manjaro Brasil I Manjaro Hispano
==> IRC Manjaro Brasil: #manjaro-br I IRC Manjaro Hispano: #manjaro-es

Offline Holmes

  • Mirror Support Team
  • ***
  • Posts: 2039
  • Brazilian and Hispanic Support Team
    • Manjaro Brasil
  • Branch: Stable
  • Desktop: Manjaro XFCE
  • GPU Card: Mobile Intel (R) 945
  • GPU driver: Non-free
  • Kernel: kernellinux
  • Skill: Novice
Re: jwm: startx not working
« Reply #8 on: 18. March 2016, 14:33:01 »
in my opinion there is nothing wrong with jwm.
even those error found by jwm -p was not affecting its functioning.

vlw fwi, Holmes :)


==> Manjaro Brasil I Manjaro Hispano
==> IRC Manjaro Brasil: #manjaro-br I IRC Manjaro Hispano: #manjaro-es

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: jwm: startx not working
« Reply #9 on: 18. March 2016, 14:40:09 »
Maybe try with
Code: [Select]
<StartupCommand>sleep 1 && pcmanfm -d --desktop-off</StartupCommand>
<StartupCommand>sleep 4 && nitrogen --restore</StartupCommand>
?
« Last Edit: 18. March 2016, 14:43:02 by eugen-b »
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: jwm: startx not working
« Reply #10 on: 18. March 2016, 14:46:58 »
I think my previous investigation shows that there must be something wrong with the config files.
Please check the syntax or maybe ask Joe or Israel to check your config? you can simply link them to our github
I am convinced it cannot have anything to do with the structure of the tools, because the default jwm session without your tray file starts fine! And the start file obviously doesn't work properly either!



;)
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline mandog

  • Held Mitglied
  • *****
  • Posts: 1921
  • Architect Forum And G+ Forum Owner With Daniel S
  • Branch: All
  • Desktop: Gnome, Mate, E19, Openbox,FLuxbox,Budgie, XFCE openRC,
  • GPU Card: nvidia
  • GPU driver: Non Free
  • Kernel: latest
  • Skill: Advanced
Re: jwm: startx not working
« Reply #11 on: 18. March 2016, 15:00:53 »
Strange as I had the same problem with arch the solution for me was to remove the Arch start icon in the tray menu and replace it with text then everything was fine.
« Last Edit: 18. March 2016, 15:03:39 by mandog »
A ENGLISHMAN IN PERU
I'm dyslexic Please do not complain about punctuation or spelling,
FANBOY,Taken from the urban dictionary
 A pathetic insult often used by fanboys themselves to try and put down people who don't like whatever it is they like.

Offline Holmes

  • Mirror Support Team
  • ***
  • Posts: 2039
  • Brazilian and Hispanic Support Team
    • Manjaro Brasil
  • Branch: Stable
  • Desktop: Manjaro XFCE
  • GPU Card: Mobile Intel (R) 945
  • GPU driver: Non-free
  • Kernel: kernellinux
  • Skill: Novice
Re: jwm: startx not working
« Reply #12 on: 18. March 2016, 15:02:16 »
i sent an email to the Israel asking him to look at the settings.

vlw fwi, Holmes :)


==> Manjaro Brasil I Manjaro Hispano
==> IRC Manjaro Brasil: #manjaro-br I IRC Manjaro Hispano: #manjaro-es

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: jwm: startx not working
« Reply #13 on: 18. March 2016, 15:12:34 »
The tray file is the only remaining problem I think, yes! :)
Regarding the background I was just stupid, because in my clean root's home there was no nitrogen/ dir present ::) ... and no conkyrc, either ...
sorry! ;D
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: jwm: startx not working
« Reply #14 on: 18. March 2016, 15:16:33 »
Yep! You just need to fix the tray config and we're good! ;D

manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin