Author Topic: [nvidia] Last update: Failed to initialize the kernel module  (Read 1130 times)

0 Members and 1 Guest are viewing this topic.

Offline spacedebris

  • Neuling
  • *
  • Posts: 1
  • I'm new. Be nice!
  • Skill: Novice
Hey ho,
I'm addicted  with manjaro through one year. Since this time I don't've such a problem like this. I'll be really graceful for any advices because my linux knowledge is basic, I've read similar topic, but nothing help. So some info:

uname -r:
Code: (javascript) [Select]
4.1.23-1-MANJARO

systemctl status systemd-modules-load.service:
Code: (javascript) [Select]
‚óŹ systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since nie 2016-05-08 19:51:44 CEST; 11min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 168 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 168 (code=exited, status=1/FAILURE)

maj 08 19:51:44 siman-e6400 systemd-modules-load[168]: Failed to insert 'nvidia': Exec format error
maj 08 19:51:44 siman-e6400 systemd-modules-load[168]: Inserted module 'nfs'
maj 08 19:51:44 siman-e6400 systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
maj 08 19:51:44 siman-e6400 systemd[1]: Failed to start Load Kernel Modules.
maj 08 19:51:44 siman-e6400 systemd[1]: systemd-modules-load.service: Unit entered failed state.
maj 08 19:51:44 siman-e6400 systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.


Xorg.0.log
Code: (javascript) [Select]
[   825.485]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[   825.490] X Protocol Version 11, Revision 0
[   825.492] Build Operating System: Linux 4.2.5-1-ARCH x86_64
[   825.495] Current Operating System: Linux siman-e6400 4.1.23-1-MANJARO #1 SMP PREEMPT Sun Apr 24 08:59:35 UTC 2016 x86_64
[   825.496] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.1-x86_64 root=UUID=36ff46c7-1a8f-4cfd-abcd-a0c1c338c108 rw quiet splash resume=UUID=3a2e7f29-dd32-4e41-878a-2ccc9f3086ee
[   825.505] Build Date: 01 November 2015  10:36:50AM
[   825.510] 
[   825.515] Current version of pixman: 0.34.0
[   825.526] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[   825.526] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   825.553] (==) Log file: "/var/log/Xorg.0.log", Time: Sun May  8 20:05:26 2016
[   825.561] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   825.569] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   825.569] (==) ServerLayout "Layout0"
[   825.569] (**) |-->Screen "Screen0" (0)
[   825.569] (**) |   |-->Monitor "Monitor0"
[   825.569] (**) |   |-->Device "Device0"
[   825.569] (**) |-->Input Device "Keyboard0"
[   825.569] (**) |-->Input Device "Mouse0"
[   825.569] (==) Automatically adding devices
[   825.569] (==) Automatically enabling devices
[   825.569] (==) Automatically adding GPU devices
[   825.569] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   825.569] Entry deleted from font path.
[   825.569] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   825.569] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   825.569] Entry deleted from font path.
[   825.569] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   825.569] (==) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/Type1/
[   825.569] (==) ModulePath set to "/usr/lib/xorg/modules"
[   825.569] (**) Extension "Composite" is enabled
[   825.569] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   825.569] (WW) Disabling Keyboard0
[   825.569] (WW) Disabling Mouse0
[   825.569] (II) Loader magic: 0x817d60
[   825.569] (II) Module ABI versions:
[   825.569] X.Org ANSI C Emulation: 0.4
[   825.569] X.Org Video Driver: 19.0
[   825.569] X.Org XInput driver : 21.1
[   825.569] X.Org Server Extension : 9.0
[   825.572] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[   825.574] (--) PCI:*(0:1:0:0) 10de:06eb:1028:0233 rev 161, Mem @ 0xf5000000/16777216, 0xe0000000/268435456, 0xf2000000/33554432, I/O @ 0x0000df00/128, BIOS @ 0x????????/131072
[   825.574] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   825.574] (II) LoadModule: "glx"
[   825.575] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   825.590] (II) Module glx: vendor="NVIDIA Corporation"
[   825.590] compiled for 4.0.2, module version = 1.0.0
[   825.590] Module class: X.Org Server Extension
[   825.590] (II) NVIDIA GLX Module  340.96  Sun Nov  8 22:06:18 PST 2015
[   825.590] (II) LoadModule: "nvidia"
[   825.590] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   825.591] (II) Module nvidia: vendor="NVIDIA Corporation"
[   825.591] compiled for 4.0.2, module version = 1.0.0
[   825.591] Module class: X.Org Video Driver
[   825.591] (II) NVIDIA dlloader X Driver  340.96  Sun Nov  8 21:46:28 PST 2015
[   825.591] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   825.591] (++) using VT number 2

[   825.591] (--) controlling tty is VT number 2, auto-enabling KeepTty
[   825.591] (II) Loading sub module "fb"
[   825.591] (II) LoadModule: "fb"
[   825.591] (II) Loading /usr/lib/xorg/modules/libfb.so
[   825.591] (II) Module fb: vendor="X.Org Foundation"
[   825.591] compiled for 1.17.4, module version = 1.0.0
[   825.591] ABI class: X.Org ANSI C Emulation, version 0.4
[   825.591] (WW) Unresolved symbol: fbGetGCPrivateKey
[   825.591] (II) Loading sub module "wfb"
[   825.591] (II) LoadModule: "wfb"
[   825.591] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   825.591] (II) Module wfb: vendor="X.Org Foundation"
[   825.591] compiled for 1.17.4, module version = 1.0.0
[   825.591] ABI class: X.Org ANSI C Emulation, version 0.4
[   825.591] (II) Loading sub module "ramdac"
[   825.591] (II) LoadModule: "ramdac"
[   825.591] (II) Module "ramdac" already built-in
[   825.693] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[   825.693] (EE) NVIDIA:     system's kernel log for additional error messages and
[   825.693] (EE) NVIDIA:     consult the NVIDIA README for details.
[   825.693] (EE) No devices detected.
[   825.693] (EE)
Fatal server error:
[   825.693] (EE) no screens found(EE)
[   825.693] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
 for help.
[   825.693] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   825.693] (EE)


inxi -G
Code: (javascript) [Select]
Graphics: Card: NVIDIA G98M [Quadro NVS 160M]
Display Server: X.org 1.17.4 driver: nvidia tty size: 180x56 Advanced Data: N/A for root out of X

mhwd-gpu --status
Code: (javascript) [Select]
Using default
Default lib32 support: true
:: status
  lib32-libGl: '/usr/lib32/nvidia/libGL.so'
  lib32-libGLESv1: '/usr/lib32/nvidia/libGLESv1_CM.so'
  lib32-libGLESv2: '/usr/lib32/nvidia/libGLESv2.so'
  lib32-libEGL: '/usr/lib32/nvidia/libEGL.so'
  libGl: '/usr/lib/nvidia/libGL.so'
  libGLESv1: '/usr/lib/nvidia/libGLESv1_CM.so'
  libGLESv2: '/usr/lib/nvidia/libGLESv2.so'
  libEGL: '/usr/lib/nvidia/libEGL.so'
  libglx: '/usr/lib/nvidia/xorg/modules/extensions/libglx.so'
  xorg configuration file: '/etc/X11/mhwd.d/nvidia.conf'

mhwd:
Code: (javascript) [Select]
0000:01:00.0 (0300:10de:06eb) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-340xx            2016.04.25               false            PCI
    video-nvidia-304xx            2016.04.25               false            PCI
         video-nouveau            2016.01.28                true            PCI
              video-nv            2012.09.18                true            PCI
            video-vesa            2012.09.18                true            PCI


0000:0c:00.0 (0200:14e4:4315) Network controller Broadcom:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
   network-broadcom-wl            2015.12.13                true            PCI