Author Topic: Canon Pixma MG2400series drivers in AUR - cannot install them  (Read 6449 times)

0 Members and 1 Guest are viewing this topic.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Canon Pixma MG2400 drivers in AUR but cannot install them
« Reply #30 on: 21. October 2015, 11:14:09 »
Well here is the thing: I just realize that I am running my own Canon mg3100 perfectly fine with nothing else installed but cnijfilter-mg3100 plus foomatic-db-engine 8)
Also I just see that cnijfilter-common-mg2400 and cnijfilter-mg2400series use the same source ;D
@cipricus would you mind trying if your printer will work with the cnijfilter-mg2400series package alone (maybe plus gutenprint but without the common-package)? If not I think I should just figure out which files I will have to make one or the other package install. It doesn't make sense at all to install two packages that use the same source ???
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline cipricus

  • Jr. Mitglied
  • **
  • Posts: 58
  • Desktop: Fluxbox
  • Kernel: linux38-x64
  • Skill: Novice
Re: Canon Pixma MG2400 drivers in AUR but cannot install them
« Reply #31 on: 21. October 2015, 11:41:18 »
Well here is the thing: I just realize that I am running my own Canon mg3100 perfectly fine with nothing else installed but cnijfilter-mg3100 plus foomatic-db-engine 8)
Also I just see that cnijfilter-common-mg2400 and cnijfilter-mg2400series use the same source ;D
@cipricus would you mind trying if your printer will work with the cnijfilter-mg2400series package alone (maybe plus gutenprint but without the common-package)? If not I think I should just figure out which files I will have to make one or the other package install. It doesn't make sense at all to install two packages that use the same source ???

Removing cnijfilter-common-mg2400 automatically removes cnijfilter-mg2400series. Then, installing cnijfilter-mg2400series I am not prompted to install cnijfilter-common-mg2400: but after completion of  installation process both packages are installed.

So, as far as I can tell, I cannot install only cnijfilter-mg2400series.

Maybe I should mention that the deb packages of the same driver present  the same situation on ubuntu-based systems: cnijfilter-mg2400series_4.00-1_amd64.deb demands cnijfilter-common_4.00-1_amd64.deb as a dependency in gdebi.

Also, printing will not work in my case without gutenprint.  I have chosen gutenprint for the good reason that it was installed automatically in Linux Mint for the same printer and on the same computer.

In fact foomatic-db-engine was also installed, but I don know when and how. When testing to uninstall it, gutenprint and cups-filters are reported to be needing it.

As Pixma mg2450 has also an integrated scanner, the driver for that is scangearmp-common (a common package).
« Last Edit: 21. October 2015, 12:23:08 by cipricus »

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Canon Pixma MG2400series drivers in AUR - cannot install them
« Reply #32 on: 21. October 2015, 12:19:51 »
Thank you. :)
Please don't change anything in your setup now that it works ;D
I will investigate more on my own...
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline cipricus

  • Jr. Mitglied
  • **
  • Posts: 58
  • Desktop: Fluxbox
  • Kernel: linux38-x64
  • Skill: Novice
Re: Canon Pixma MG2400series drivers in AUR - cannot install them
« Reply #33 on: 21. October 2015, 12:25:06 »
Thank you. :)
Please don't change anything in your setup now that it works ;D
I will investigate more on my own...

See the changes made in my last post - in fact foomatic-db-engine  package was on my system too. Possibly installed with gutenprint or cups-filters. I don't remember if the latter were default on the system or it's me who installed them.

Offline cipricus

  • Jr. Mitglied
  • **
  • Posts: 58
  • Desktop: Fluxbox
  • Kernel: linux38-x64
  • Skill: Novice
Re: Canon Pixma MG2400series drivers in AUR - cannot install them
« Reply #34 on: 05. December 2016, 14:25:06 »
This was marked as solved and should work for the stable Manjaro of  October 2015. It doesn't work with 16.10.2 Fringilla, possibly because of a gtk3 update. A new post here: https://forum.manjaro.org/t/cannot-print-with-canon-pixma-mg2400series-in-16-10-2-fringilla-xfce/13723