Poll

Did you experience any issue with this update?

No issues, everything went smoothly.
132 (62.9%)
Yes there was an issue. I was able to resolve it myself. (Please post your solution)
30 (14.3%)
Yes I am currently experiencing an issue due to the update. (Please post about it)
48 (22.9%)

Total Members Voted: 210

Author Topic: [Update] 2016-04-26 - Cinnamon 3.0, Pamac, Gnome 3.20, KDE, Virtualbox  (Read 28848 times)

0 Members and 1 Guest are viewing this topic.

Offline kainonergon

  • Neuling
  • *
  • Posts: 19
  • Branch: testing
  • Desktop: i3, Xfce
  • GPU Card: IntelĀ® HD Graphics 4400
  • GPU driver: free
  • Kernel: linux48-x64
  • Skill: Intermediate
Great update. No problems. Thanks!

Offline CyberWolf2k14

  • Held Mitglied
  • *****
  • Posts: 1184
  • Computers make very fast, very accurate mistakes.
  • Branch: Stable-sysd229-LightDM
  • Desktop: MATE/Cinnamon/GNOME
  • GPU Card: nVidia GeForce GT740
  • GPU driver: nVidia-NF-364.19
  • Kernel: 4.4.9x64 / 4.2.8.9x64 / 4.1.23x64
  • Skill: Intermediate
Just a later addition to those who may come to this area:
YES, themes will be broken UNTIL they are brought into GTK+3 compliance, and YES definitely change the LightDM theme to one that IS support (Vertes is a good choice).
PowerSpec Quad core Intel Core i5-4690K w/ 16GB RAM
Dual Boot = Win 7 Ult x64 and Manjaro 15.12 x64
===================================================
"A computer lets you make more mistakes faster than any invention in human history...
with the possible exceptions of handguns and tequila".

Offline viking60

  • Sr. Mitglied
  • ****
  • Posts: 388
    • bjoernvold.com
  • Branch: stable
  • Desktop: openbox
  • GPU Card: NVIDIA GT200b [GeForce GTX 275]
  • GPU driver: nonfree
  • Kernel: linux4.1-x86_64
  • Skill: Intermediate
Thanks Manjaro team - I am happy as a peach here.

Steam works, VM works, MDM XFCE works - no noticeable problems with the themes but I changed to vertex anyway - because it looks good.

Offline aaditya

  • OpenRC Team
  • ****
  • Posts: 2844
    • My Website
  • Branch: Testing
  • Desktop: Xfce, Openbox
  • GPU Card: Intel HD 4000
  • Kernel: Linux 4.4 x86_64
  • Skill: Intermediate
I am updating on a VB VM, running Manjaro with OpenRC.  After update, on reboot the boot process hangs just before lightdm, so I have a black screen and a flashing underscore cursor...it is taking no kb input, and the only action I can take is to close the vm, or issue a ctrl-alt-del through the VB interface....

UPDATE: alt-f1 produces a tty, so I can log in.  rc-status says xdm has crashed -- do we have a fix for this?
Hi, have a look here:
https://forum.manjaro.org/index.php?topic=33422.0

Offline viking60

  • Sr. Mitglied
  • ****
  • Posts: 388
    • bjoernvold.com
  • Branch: stable
  • Desktop: openbox
  • GPU Card: NVIDIA GT200b [GeForce GTX 275]
  • GPU driver: nonfree
  • Kernel: linux4.1-x86_64
  • Skill: Intermediate
I had this in a VB with pure Arch and installing xorg-drivers fixed it for me (probably just luck).
« Last Edit: 27. April 2016, 19:00:56 by viking60 »

Offline beardedragon

  • Held Mitglied
  • *****
  • Posts: 500
  • Branch: Stable OpenRC & Testing Systemd
  • Desktop: Xfce 4.12.3 (Gtk 2.24.28)
  • GPU Card: NVIDIA GK208 [GeForce GT 720/PCIe/SSE2]
  • GPU driver: 4.5.0 NVIDIA 361.42(non-free)
  • Kernel: 4.4-6 & 4.6-rc5-MANJARO-x86_64
  • Skill: Advanced
Stabl;e update good, thanks team.
Robert Collard Madison, WI
Lenova K450e  8GB RAM
ManjaroLinux 15.12 Capella

Offline lightbeam

  • Sr. Mitglied
  • ****
  • Posts: 286
  • Branch: Stable as in: "Whoa, Nelly!"
  • Desktop: Wide Openbox
  • GPU Card: AMD Radeon Xpress 200 Series - Methuselah Edition
  • GPU driver: Free as in Lunch
  • Kernel: Linux44, i686
  • Skill: Intermediate
I'll see what I can do, but my desktop theme and Firefox theme are no longer working right.  Arc-Dark.  Also, since two updates ago, system applications still fail to launch from the menu.  I have to launch them from terminal. 

It would be a good idea for developers to post why things are breaking a lot lately.  Every update previous to the last three went smoothly for me.  I might have had problems with packages not updating, but they were easily and quickly solved.  These latest updates, however, have been annoying as hell.
 
 >:(

Update:  Managed to fix my theme.  But I would still like to know what to do so that I can begin to launch system applications from the menu again.

Anyway, my frustration was not aimed at anybody.  It was just me venting in public -- classy as it was.
« Last Edit: 27. April 2016, 19:53:22 by lightbeam »
---------------------------------------------------
I make you look good. 8)

Offline JohnBlood

  • Jr. Mitglied
  • **
  • Posts: 51
    • Wired World Report
  • Branch: Stable
  • Desktop: XFCE
  • GPU driver: Free
  • Kernel: linux42-x64
  • Skill: Novice
I tried to run Steam after this update and nothing happened. I ran the steam command in the terminal and goes this message:

Code: [Select]
Running Steam on manjarolinux 15.12 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1459463254)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Any recommendations?
Check out the latest Manjaro news and tips at the  Manjaro Gazette.

Offline dompster

  • Neuling
  • *
  • Posts: 3
  • I'm new. Be nice!
  • Skill: Novice
I'm having a similar problem with XFCE that others have mentioned in this thread. After booting i get a black screen with a grey bar on the bottom that occasionally flickers. Things I've tried:

installing themes: sudo pacman -S vertex-maia-themes vertex-maia-icon-theme xcursor-maia

reinstalling graphics drivers using mhwd

using kernel 4.1.23-1 instead of 4.4.8-1

downgrading gtk3 3.20 to 3.18 and lib32-gtk 3.20 to 3.18

So far nothing has worked. Anyone have any ideas?

Offline lukstux

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: XFCE4
  • GPU Card: Intel Graphics 4000
  • GPU driver: OpenSource
  • Kernel: linux44-x64 LLTS
  • Skill: Novice
I tried to run Steam after this update and nothing happened. I ran the steam command in the terminal and goes this message:

Code: [Select]
Running Steam on manjarolinux 15.12 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1459463254)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Any recommendations?

A guy told me in the last page to use this code in a terminal

Code: [Select]
find ~/.steam/root/ -name "libgpg-error.so*" -print -delete
It worked for me, hope it helps u too :]

Offline lyx

  • Neuling
  • *
  • Posts: 6
  • I'm new. Be nice!
  • Desktop: Xfce4
  • GPU Card: Nvidia Geforce 920M
  • GPU driver: non-free with bumblebee
  • Kernel: linux44-4.4.8-1-86x64
  • Skill: Novice
I think this update would break lightdm webkit greeter because I believe that's what happens to mine.

Offline JohnBlood

  • Jr. Mitglied
  • **
  • Posts: 51
    • Wired World Report
  • Branch: Stable
  • Desktop: XFCE
  • GPU driver: Free
  • Kernel: linux42-x64
  • Skill: Novice
A guy told me in the last page to use this code in a terminal

Code: [Select]
find ~/.steam/root/ -name "libgpg-error.so*" -print -delete
It worked for me, hope it helps u too :]

That fixed it. Thanks. I guess it would help to read through the forum feed (of whatever it's called).
Check out the latest Manjaro news and tips at the  Manjaro Gazette.

Offline aggraef

  • Neuling
  • *
  • Posts: 4
  • Branch: stable
  • Desktop: xfce
  • Skill: Advanced
The Emacs 24 toolbar comes up empty after the GTK update. Has anyone found a solution for that yet?

Offline jubileu

  • Neuling
  • *
  • Posts: 17
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Xcfe
  • Skill: Intermediate
Firefox on Xfce visually broken
« Reply #103 on: 27. April 2016, 22:09:07 »
Firefox on Xfce also broke for me, visually. No scrollbutton on the scrollbar, low contrast on selected text, no text on url suggestions, no text on right click. Guess I'll have to stick to Chromium for a while...

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Regarding themes it would be easier to read the first post. We already added some workarounds for steam and ufw ...