Poll

Did you experience any issue with this update?

No issues, everything went smoothly.
132 (62.9%)
Yes there was an issue. I was able to resolve it myself. (Please post your solution)
30 (14.3%)
Yes I am currently experiencing an issue due to the update. (Please post about it)
48 (22.9%)

Total Members Voted: 210

Author Topic: [Update] 2016-04-26 - Cinnamon 3.0, Pamac, Gnome 3.20, KDE, Virtualbox  (Read 29107 times)

0 Members and 1 Guest are viewing this topic.

Offline mikronimo

  • Neuling
  • *
  • Posts: 28
  • Branch: stable
  • Desktop: KDE Plasma 5.5.5
  • GPU Card: intel HD 4600 (integrated with Intel i3 4330 3.5 GHz Haswell)
  • GPU driver: open
  • Kernel: 4.1.19-1-MANJARO
  • Skill: Novice
So far, on my KDE Plasma, all well... very big update, a lot of work, i guess... thank you. +10

Offline tyranthraxus

  • Neuling
  • *
  • Posts: 24
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: XFCE/OB + Cinnamon/OB
  • GPU Card: Intel 4500MHD + GeForce GT 420
  • GPU driver: Free + non-free
  • Kernel: linux318-x64 + linux42-x64
  • Skill: Intermediate
So far so good on Cinnamon. Libre Office looks a little wonky, missing menu text and so on... but I mainly use WPS, so I'm not too bothered ;)
Otherwise I haven't noticed anything broken with this update.

Offline notfound

  • Neuling
  • *
  • Posts: 5
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Gnome
  • GPU Card: ATI
  • Skill: Novice
Everything is fine, but Steam is no longer working:
Code: [Select]
Running Steam on manjarolinux 16.02 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1461721017)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

This fixed my issue:
Code: [Select]
find ~/.steam/root/ -name "libgpg-error.so*" -print -delete

Thank you! This did the trick.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
I use Libreoffice Fresh on Xfce. It's the only app affected. Scroll bars don't look good also.
So the difference is obviously between -still and -fresh
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline lukstux

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: XFCE4
  • GPU Card: Intel Graphics 4000
  • GPU driver: OpenSource
  • Kernel: linux44-x64 LLTS
  • Skill: Novice
Now I can say: smooth update! except for some bugs in vertex-maia-theme in the lock screen.

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Hello, after the update my system is now broken and I'm unable to login. The update appeared to apply fine under my regular XFCE install (not a virtual machine) with no errors, but after reboot, I now boot to a blank/black screen instead of a login screen (sometimes with a blinking cursor, sometimes with nothing at all.) Thankfully, I am able to escape the blank screen with Ctrl-Alt-F2, but nothing I've tried will let me back to the login/graphical interface.

Use mhwd to reinstall your graphics drivers.
https://wiki.manjaro.org/index.php/Configure_Graphics_Cards

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Now I can say: smooth update! except for some bugs in vertex-maia-theme in the lock screen.

You did change LightDM's theme to Vertex-Maia in the LightDM GTK Greeter Settings?

Offline pantuts

  • Neuling
  • *
  • Posts: 3
    • Pantuts
  • Skill: Intermediate
Updates installed. However, it broke my Arc theme.

Offline AV_Aca

  • Neuling
  • *
  • Posts: 13
  • Branch: Stable
  • Desktop: XFCE
  • GPU Card: nVidia 8600gt
  • GPU driver: ForceWare
  • Kernel: 4.4.x x86_64
  • Skill: Novice
No problems (except themes issues, of course). Great job, as usual. Thanks MANJARO team.

Offline Trinakrian

  • Vollwertiges Mitglied
  • ***
  • Posts: 108
  • Skill: Intermediate
Hello, after the update my system is now broken and I'm unable to login. The update appeared to apply fine under my regular XFCE install (not a virtual machine) with no errors, but after reboot, I now boot to a blank/black screen instead of a login screen (sometimes with a blinking cursor, sometimes with nothing at all.) Thankfully, I am able to escape the blank screen with Ctrl-Alt-F2, but nothing I've tried will let me back to the login/graphical interface.

I have Linux kernels: 318, 41 and 44 installed. None of which will allow me to boot into my system any more, they all result in the same blank screen/lockup.

This is the first time that I've ever had a stable Manjaro update completely break my system and I really hope that someone is able to figure this out soon. Please let me know if you need any more specific information. Thanks

Did you follow the directions on the update where it says to use mhwd to set your graphics card? Be sure to check notes every time you update.

You can reboot, press 'e' to edit the boot line in GRUB and add a 3 to the end of the line, to get to a command line and use mhwd to set your drivers. Reboot and you should be OK.
« Last Edit: 27. April 2016, 16:24:02 by Trinakrian »

Offline lukstux

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: XFCE4
  • GPU Card: Intel Graphics 4000
  • GPU driver: OpenSource
  • Kernel: linux44-x64 LLTS
  • Skill: Novice
Not so smooth as I tought, steam is not working
Code: [Select]
[lucas@LucasFB ~]$ steam
Running Steam on manjarolinux 15.12 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1459463254)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Offline lukstux

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: XFCE4
  • GPU Card: Intel Graphics 4000
  • GPU driver: OpenSource
  • Kernel: linux44-x64 LLTS
  • Skill: Novice
Even in Pre3 release, steam is dead x.x

Code: [Select]
[manjaro@manjaro ~]$ steam
Running Steam on manjarolinux 16.06-pre3 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Offline notfound

  • Neuling
  • *
  • Posts: 5
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Gnome
  • GPU Card: ATI
  • Skill: Novice
Not so smooth as I tought, steam is not working
Code: [Select]
[lucas@LucasFB ~]$ steam
Running Steam on manjarolinux 15.12 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1459463254)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Did you try copying and pasting this into a terminal:

Code: [Select]
find ~/.steam/root/ -name "libgpg-error.so*" -print -delete

Offline lukstux

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: XFCE4
  • GPU Card: Intel Graphics 4000
  • GPU driver: OpenSource
  • Kernel: linux44-x64 LLTS
  • Skill: Novice
Did you try copying and pasting this into a terminal:

Code: [Select]
find ~/.steam/root/ -name "libgpg-error.so*" -print -delete

It workerd after 3 or 4 tryies x.X
Idk why, but thanks.
« Last Edit: 27. April 2016, 16:51:50 by lukstux »

Offline lukstux

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: XFCE4
  • GPU Card: Intel Graphics 4000
  • GPU driver: OpenSource
  • Kernel: linux44-x64 LLTS
  • Skill: Novice
You did change LightDM's theme to Vertex-Maia in the LightDM GTK Greeter Settings?

No, my mistake, now it's fine, thanks :)