Author Topic: New language added but no systemtray icon.  (Read 267 times)

0 Members and 1 Guest are viewing this topic.

Offline Imatux

  • Neuling
  • *
  • Posts: 10
  • I'm new. Be nice!
  • Skill: Novice
New language added but no systemtray icon.
« on: 22. April 2016, 16:02:18 »
I added a new language to my system, but there is no way to pick in whitch language i want to wright, and there is no systemtray icon! do i have to install it my self?

Offline wvi

  • Neuling
  • *
  • Posts: 6
    • Github
  • Desktop: Fluxbox
  • Skill: Intermediate
Re: New language added but no systemtray icon.
« Reply #1 on: 23. April 2016, 09:56:11 »
Code: [Select]
# Switch between us and cz keyboards on alt + left shift
# Mod1 is ALT, Shift is what printed by xev upon Shift key press
Mod1 Shift :Exec if [[ $(setxkbmap -query|awk '/layout:/ {print $2}') == 'us' ]]; then setxkbmap cz; else setxkbmap us; fi

This little thing in my .fluxbox/keys switches between czech and us keyboards. There is no indicator anywhere but I wouldn't really use it anyway.
You can also add the language selection to your menu see http://fluxbox-wiki.org/category/howtos/en/Switch_Keyboard_layout.html

On the graphical side of things you can use for example xfce4-xkb-plugin (http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin) but I haven't tried it in Fluxbox.

Offline Imatux

  • Neuling
  • *
  • Posts: 10
  • I'm new. Be nice!
  • Skill: Novice
Re: New language added but no systemtray icon.
« Reply #2 on: 23. April 2016, 11:28:59 »
found solution here: https://forum.manjaro.org/index.php?topic=27388.0
on the furom! thanks for the help!