Author Topic: Optimus laptop, start dedicated xserver on nvidia  (Read 397 times)

0 Members and 1 Guest are viewing this topic.

Offline Mutant22

  • Neuling
  • *
  • Posts: 2
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: KDE 4.14.8
  • GPU Card: Intel Haswell integrated and Nvidia geforce 840M
  • GPU driver: Intel free, Nvidia non-free
  • Kernel: linux40-x64
  • Skill: Novice
Optimus laptop, start dedicated xserver on nvidia
« on: 11. May 2016, 08:52:37 »
Hello.
I have ASUS X550LN notebook with Intel and Nvidia graphic cards. Bubmlebee is working, but starting dedicated xserver on nvidia card always gave me better fps. I was using nvidia-xrun package (from AUR) to start it. But after system update I get only black screen. I dont know if the last one broke it, or some older one. I was not gaming much recently.
Here is my nvidia.xorg.conf:
Code: [Select]
Section "Files"
  ModulePath "/usr/lib/nvidia"
  ModulePath "/usr/lib32/nvidia"
  ModulePath "/usr/lib32/nvidia/xorg/modules"
  ModulePath "/usr/lib32/xorg/modules"
  ModulePath "/usr/lib64/nvidia/xorg/modules"
  ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerLayout"
  Identifier "layout"
  Screen 1 "nvidia"
  Inactive "intel"
EndSection

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
  BusID "PCI:4:0:0"
EndSection

Section "Screen"
  Identifier "nvidia"
  Device "nvidia"
  Option "AllowEmptyInitialConfiguration" "Yes"
  Option "UseDisplayDevice" "none"
EndSection

Section "Device"
  Identifier "intel"
  Driver "modesetting"
  Option "AccelMethod" "none"
EndSection

Section "Screen"
  Identifier "intel" 
  Device "intel"
EndSection

In nvidia-xinitrc i have:
Code: [Select]
export LD_LIBRARY_PATH=/usr/lib64/nvidia/:/usr/lib32/nvidia:/usr/lib:$LD_LIBRARY_PATH
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

And finally my xorg.log:
Code: [Select]
[  1215.965]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[  1215.966] X Protocol Version 11, Revision 0
[  1215.966] Build Operating System: Linux 4.2.5-1-ARCH x86_64
[  1215.966] Current Operating System: Linux a05-0331a 4.5.3-1-MANJARO #1 SMP PREEMPT Thu May 5 16:40:58 UTC 2016 x86_64
[  1215.966] Kernel command line: BOOT_IMAGE=/vmlinuz-4.5-x86_64 root=UUID=1171a9c5-615e-4d4f-830a-2b83d850360e rw resume=UUID=f02581bf-436d-4f43-898d-94e8c8269f76 acpi_osi=
[  1215.966] Build Date: 01 November 2015  10:36:50AM
[  1215.966] 
[  1215.966] Current version of pixman: 0.34.0
[  1215.966] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[  1215.966] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1215.966] (==) Log file: "/home/radko/.local/share/xorg/Xorg.1.log", Time: Wed May 11 08:35:45 2016
[  1215.967] (++) Using config file: "/etc/X11/nvidia-xorg.conf"
[  1215.967] (EE) Unable to locate/open config directory: "nvidia-xorg.conf.d"
[  1215.967] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1215.967] (==) ServerLayout "layout"
[  1215.967] (**) |-->Screen "nvidia" (1)
[  1215.967] (**) |   |-->Monitor "<default monitor>"
[  1215.968] (**) |   |-->Device "nvidia"
[  1215.968] (==) No monitor specified for screen "nvidia".
Using a default monitor configuration.
[  1215.968] (**) |-->Inactive Device "intel"
[  1215.968] (==) Automatically adding devices
[  1215.968] (==) Automatically enabling devices
[  1215.968] (==) Automatically adding GPU devices
[  1215.968] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  1215.968] Entry deleted from font path.
[  1215.968] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  1215.968] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  1215.968] Entry deleted from font path.
[  1215.968] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  1215.968] (==) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/Type1/
[  1215.968] (**) ModulePath set to "/usr/lib/nvidia,/usr/lib32/nvidia,/usr/lib32/nvidia/xorg/modules,/usr/lib32/xorg/modules,/usr/lib64/nvidia/xorg/modules,/usr/lib64/xorg/modules"
[  1215.968] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[  1215.968] (II) Loader magic: 0x817d60
[  1215.968] (II) Module ABI versions:
[  1215.968] X.Org ANSI C Emulation: 0.4
[  1215.968] X.Org Video Driver: 19.0
[  1215.968] X.Org XInput driver : 21.1
[  1215.968] X.Org Server Extension : 9.0
[  1215.971] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c3
[  1215.971] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1215.972] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[  1215.973] (--) PCI:*(0:0:2:0) 8086:0a16:1043:131d rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[  1215.973] (--) PCI: (0:4:0:0) 10de:1341:0000:0000 rev 162, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
[  1215.973] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  1215.973] (II) LoadModule: "glx"
[  1216.022] (II) Loading /usr/lib/nvidia/xorg/modules/extensions/libglx.so
[  1216.439] (II) Module glx: vendor="NVIDIA Corporation"
[  1216.439] compiled for 4.0.2, module version = 1.0.0
[  1216.439] Module class: X.Org Server Extension
[  1216.449] (II) NVIDIA GLX Module  364.19  Tue Apr 19 14:10:52 PDT 2016
[  1216.462] (II) LoadModule: "nvidia"
[  1216.536] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  1216.599] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1216.599] compiled for 4.0.2, module version = 1.0.0
[  1216.599] Module class: X.Org Video Driver
[  1216.602] (II) LoadModule: "modesetting"
[  1216.603] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[  1216.616] (II) Module modesetting: vendor="X.Org Foundation"
[  1216.616] compiled for 1.17.4, module version = 1.17.4
[  1216.616] Module class: X.Org Video Driver
[  1216.616] ABI class: X.Org Video Driver, version 19.0
[  1216.616] (II) NVIDIA dlloader X Driver  364.19  Tue Apr 19 13:48:55 PDT 2016
[  1216.616] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1216.616] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  1216.616] (++) using VT number 6

[  1216.616] (--) controlling tty is VT number 6, auto-enabling KeepTty
[  1216.616] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[  1216.617] (II) Loading sub module "fb"
[  1216.617] (II) LoadModule: "fb"
[  1216.617] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  1216.624] (II) Module fb: vendor="X.Org Foundation"
[  1216.624] compiled for 1.17.4, module version = 1.0.0
[  1216.624] ABI class: X.Org ANSI C Emulation, version 0.4
[  1216.624] (II) Loading sub module "wfb"
[  1216.624] (II) LoadModule: "wfb"
[  1216.625] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[  1216.639] (II) Module wfb: vendor="X.Org Foundation"
[  1216.639] compiled for 1.17.4, module version = 1.0.0
[  1216.639] ABI class: X.Org ANSI C Emulation, version 0.4
[  1216.639] (II) Loading sub module "ramdac"
[  1216.639] (II) LoadModule: "ramdac"
[  1216.639] (II) Module "ramdac" already built-in
[  1216.653] (II) modeset(G0): using drv /dev/dri/card0
[  1216.653] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[  1216.653] (II) NVIDIA(0): Creating default Display subsection in Screen section
"nvidia" for depth/fbbpp 24/32
[  1216.653] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  1216.653] (==) NVIDIA(0): RGB weight 888
[  1216.653] (==) NVIDIA(0): Default visual is TrueColor
[  1216.653] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  1216.654] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration" "Yes"
[  1216.654] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[  1216.654] (**) NVIDIA(0): Enabling 2D acceleration
[  1216.654] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[  1216.654] (**) NVIDIA(0):     mode
[  1216.826] (II) NVIDIA(0): NVIDIA GPU GeForce 840M (GM108-A) at PCI:4:0:0 (GPU-0)
[  1216.826] (--) NVIDIA(0): Memory: 2097152 kBytes
[  1216.826] (--) NVIDIA(0): VideoBIOS: 82.08.13.00.0f
[  1216.826] (II) NVIDIA(0): Detected PCI Express Link width: 4X
[  1216.826] (II) NVIDIA(0): Validated MetaModes:
[  1216.826] (II) NVIDIA(0):     "NULL"
[  1216.826] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[  1216.826] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[  1216.826] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[  1216.826] (==) modeset(G0): Depth 24, (==) framebuffer bpp 32
[  1216.826] (**) modeset(G0): Option "AccelMethod" "none"
[  1216.826] (==) modeset(G0): RGB weight 888
[  1216.826] (==) modeset(G0): Default visual is TrueColor
[  1216.826] (**) modeset(G0): glamor disabled
[  1216.826] (II) modeset(G0): ShadowFB: preferred YES, enabled YES
[  1216.830] (II) modeset(G0): Output eDP-1-0 has no monitor section
[  1216.830] (II) modeset(G0): Output DisplayPort-1-0 has no monitor section
[  1216.936] (II) modeset(G0): Output HDMI-1-0 has no monitor section
[  1216.939] (II) modeset(G0): EDID for output eDP-1-0
[  1216.939] (II) modeset(G0): Manufacturer: LGD  Model: 3db  Serial#: 0
[  1216.939] (II) modeset(G0): Year: 2012  Week: 0
[  1216.939] (II) modeset(G0): EDID Version: 1.3
[  1216.939] (II) modeset(G0): Digital Display Input
[  1216.939] (II) modeset(G0): Max Image Size [cm]: horiz.: 35  vert.: 19
[  1216.939] (II) modeset(G0): Gamma: 2.20
[  1216.939] (II) modeset(G0): No DPMS capabilities specified
[  1216.939] (II) modeset(G0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[  1216.939] (II) modeset(G0): First detailed timing is preferred mode
[  1216.939] (II) modeset(G0): redX: 0.578 redY: 0.344   greenX: 0.337 greenY: 0.571
[  1216.939] (II) modeset(G0): blueX: 0.159 blueY: 0.120   whiteX: 0.313 whiteY: 0.329
[  1216.939] (II) modeset(G0): Manufacturer's mask: 0
[  1216.939] (II) modeset(G0): Supported detailed timing:
[  1216.939] (II) modeset(G0): clock: 76.8 MHz   Image Size:  345 x 194 mm
[  1216.939] (II) modeset(G0): h_active: 1366  h_sync: 1414  h_sync_end 1446 h_blank_end 1618 h_border: 0
[  1216.939] (II) modeset(G0): v_active: 768  v_sync: 771  v_sync_end 776 v_blanking: 790 v_border: 0
[  1216.939] (II) modeset(G0):  LG Display
[  1216.939] (II) modeset(G0):  LP156WH3-TLT1
[  1216.939] (II) modeset(G0): EDID (in hex):
[  1216.939] (II) modeset(G0): 00ffffffffffff0030e4db0300000000
[  1216.939] (II) modeset(G0): 00160103802313780a05f59458569228
[  1216.939] (II) modeset(G0): 1e505400000001010101010101010101
[  1216.939] (II) modeset(G0): 010101010101fb1d56fc500016303020
[  1216.939] (II) modeset(G0): 350059c2100000190000000000000000
[  1216.939] (II) modeset(G0): 00000000000000000000000000fe004c
[  1216.939] (II) modeset(G0): 4720446973706c61790a2020000000fe
[  1216.939] (II) modeset(G0): 004c503135365748332d544c54310006
[  1216.940] (II) modeset(G0): Printing probed modes for output eDP-1-0
[  1216.940] (II) modeset(G0): Modeline "1366x768"x60.0   76.75  1366 1414 1446 1618  768 771 776 790 -hsync -vsync (47.4 kHz eP)
[  1216.940] (II) modeset(G0): Modeline "1024x768"x120.1  133.47  1024 1100 1212 1400  768 768 770 794 doublescan -hsync +vsync (95.3 kHz d)
[  1216.940] (II) modeset(G0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[  1216.940] (II) modeset(G0): Modeline "960x720"x120.0  117.00  960 1024 1128 1300  720 720 722 750 doublescan -hsync +vsync (90.0 kHz d)
[  1216.940] (II) modeset(G0): Modeline "928x696"x120.1  109.15  928 976 1088 1264  696 696 698 719 doublescan -hsync +vsync (86.4 kHz d)
[  1216.940] (II) modeset(G0): Modeline "896x672"x120.0  102.40  896 960 1060 1224  672 672 674 697 doublescan -hsync +vsync (83.7 kHz d)
[  1216.940] (II) modeset(G0): Modeline "800x600"x120.0   81.00  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
[  1216.940] (II) modeset(G0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[  1216.940] (II) modeset(G0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[  1216.940] (II) modeset(G0): Modeline "700x525"x120.0   61.00  700 744 820 940  525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
[  1216.940] (II) modeset(G0): Modeline "640x512"x120.0   54.00  640 664 720 844  512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
[  1216.940] (II) modeset(G0): Modeline "640x480"x120.0   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
[  1216.940] (II) modeset(G0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[  1216.940] (II) modeset(G0): Modeline "512x384"x120.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[  1216.940] (II) modeset(G0): Modeline "400x300"x120.6   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[  1216.940] (II) modeset(G0): Modeline "400x300"x112.7   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
[  1216.940] (II) modeset(G0): Modeline "320x240"x120.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[  1216.940] (II) modeset(G0): EDID for output DisplayPort-1-0
[  1217.046] (II) modeset(G0): EDID for output HDMI-1-0
[  1217.046] (II) modeset(G0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  1217.046] (==) modeset(G0): DPI set to (96, 96)
[  1217.046] (II) Loading sub module "fb"
[  1217.046] (II) LoadModule: "fb"
[  1217.047] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  1217.047] (II) Module fb: vendor="X.Org Foundation"
[  1217.047] compiled for 1.17.4, module version = 1.0.0
[  1217.047] ABI class: X.Org ANSI C Emulation, version 0.4
[  1217.047] (II) Loading sub module "shadow"
[  1217.047] (II) LoadModule: "shadow"
[  1217.047] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[  1217.064] (II) Module shadow: vendor="X.Org Foundation"
[  1217.064] compiled for 1.17.4, module version = 1.1.0
[  1217.064] ABI class: X.Org ANSI C Emulation, version 0.4
[  1217.064] (--) Depth 24 pixmap format is 32 bpp
[  1217.064] (==) modeset(G0): Backing store enabled
[  1217.064] (==) modeset(G0): Silken mouse enabled
[  1217.064] (II) modeset(G0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  1217.064] (==) modeset(G0): DPMS enabled
[  1217.064] (WW) modeset(G0): Option "AllowEmptyInitialConfiguration" is not used
[  1217.064] (WW) modeset(G0): Option "UseDisplayDevice" is not used
[  1217.377] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[  1217.377] (II) NVIDIA:     access.
[  1217.381] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[  1217.381] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[  1217.381] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[  1217.381] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[  1217.381] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[  1217.381] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[  1217.381] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[  1217.381] (II) NVIDIA(0):     Config Options in the README.
[  1217.422] (II) NVIDIA(0): Built-in logo is bigger than the screen.
[  1217.422] (II) NVIDIA(0): Setting mode "NULL"
[  1217.446] (==) NVIDIA(0): Disabling shared memory pixmaps
[  1217.446] (==) NVIDIA(0): Backing store enabled
[  1217.446] (==) NVIDIA(0): Silken mouse enabled
[  1217.446] (==) NVIDIA(0): DPMS enabled
[  1217.446] (II) Loading sub module "dri2"
[  1217.446] (II) LoadModule: "dri2"
[  1217.446] (II) Module "dri2" already built-in
[  1217.446] (II) NVIDIA(0): [DRI2] Setup complete
[  1217.446] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[  1217.446] (--) RandR disabled
[  1217.450] (II) Initializing extension GLX
[  1217.450] (II) Indirect GLX disabled.
[  1217.450] (II) modeset(G0): Damage tracking initialized
[  1217.647] (II) config/udev: Adding input device Power Button (/dev/input/event5)
[  1217.647] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  1217.647] (II) LoadModule: "evdev"
[  1217.648] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  1217.648] (II) Module evdev: vendor="X.Org Foundation"
[  1217.648] compiled for 1.17.4, module version = 2.10.2
[  1217.648] Module class: X.Org XInput Driver
[  1217.648] ABI class: X.Org XInput driver, version 21.1
[  1217.648] (II) systemd-logind: got fd for /dev/input/event5 13:69 fd 25 paused 0
[  1217.648] (II) Using input driver 'evdev' for 'Power Button'
[  1217.648] (**) Power Button: always reports core events
[  1217.649] (**) evdev: Power Button: Device: "/dev/input/event5"
[  1217.649] (--) evdev: Power Button: Vendor 0 Product 0x1
[  1217.649] (--) evdev: Power Button: Found keys
[  1217.649] (II) evdev: Power Button: Configuring as keyboard
[  1217.649] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input9/event5"
[  1217.649] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  1217.649] (**) Option "xkb_rules" "evdev"
[  1217.649] (II) config/udev: Adding input device Video Bus (/dev/input/event7)
[  1217.649] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  1217.649] (II) systemd-logind: got fd for /dev/input/event7 13:71 fd 26 paused 0
[  1217.649] (II) Using input driver 'evdev' for 'Video Bus'
[  1217.649] (**) Video Bus: always reports core events
[  1217.649] (**) evdev: Video Bus: Device: "/dev/input/event7"
[  1217.649] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  1217.649] (--) evdev: Video Bus: Found keys
[  1217.649] (II) evdev: Video Bus: Configuring as keyboard
[  1217.649] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input11/event7"
[  1217.649] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[  1217.649] (**) Option "xkb_rules" "evdev"
[  1217.650] (II) config/udev: Adding input device Video Bus (/dev/input/event6)
[  1217.650] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  1217.650] (II) systemd-logind: got fd for /dev/input/event6 13:70 fd 27 paused 0
[  1217.650] (II) Using input driver 'evdev' for 'Video Bus'
[  1217.650] (**) Video Bus: always reports core events
[  1217.650] (**) evdev: Video Bus: Device: "/dev/input/event6"
[  1217.650] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  1217.650] (--) evdev: Video Bus: Found keys
[  1217.650] (II) evdev: Video Bus: Configuring as keyboard
[  1217.650] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:12/LNXVIDEO:00/input/input10/event6"
[  1217.650] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[  1217.650] (**) Option "xkb_rules" "evdev"
[  1217.651] (II) config/udev: Adding input device Lid Switch (/dev/input/event3)
[  1217.651] (II) No input driver specified, ignoring this device.
[  1217.651] (II) This device may have been added with another device file.
[  1217.651] (II) config/udev: Adding input device Sleep Button (/dev/input/event4)
[  1217.651] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[  1217.651] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 28 paused 0
[  1217.651] (II) Using input driver 'evdev' for 'Sleep Button'
[  1217.651] (**) Sleep Button: always reports core events
[  1217.651] (**) evdev: Sleep Button: Device: "/dev/input/event4"
[  1217.651] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[  1217.651] (--) evdev: Sleep Button: Found keys
[  1217.651] (II) evdev: Sleep Button: Configuring as keyboard
[  1217.651] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input8/event4"
[  1217.651] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[  1217.651] (**) Option "xkb_rules" "evdev"
[  1217.652] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=3 (/dev/input/event10)
[  1217.652] (II) No input driver specified, ignoring this device.
[  1217.652] (II) This device may have been added with another device file.
[  1217.652] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=7 (/dev/input/event11)
[  1217.652] (II) No input driver specified, ignoring this device.
[  1217.652] (II) This device may have been added with another device file.
[  1217.652] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=8 (/dev/input/event12)
[  1217.652] (II) No input driver specified, ignoring this device.
[  1217.652] (II) This device may have been added with another device file.
[  1217.652] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event8)
[  1217.652] (II) No input driver specified, ignoring this device.
[  1217.652] (II) This device may have been added with another device file.
[  1217.653] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event9)
[  1217.653] (II) No input driver specified, ignoring this device.
[  1217.653] (II) This device may have been added with another device file.
[  1217.653] (II) config/udev: Adding input device A4TECH USB Device (/dev/input/event1)
[  1217.653] (**) A4TECH USB Device: Applying InputClass "evdev keyboard catchall"
[  1217.654] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 29 paused 0
[  1217.654] (II) Using input driver 'evdev' for 'A4TECH USB Device'
[  1217.654] (**) A4TECH USB Device: always reports core events
[  1217.654] (**) evdev: A4TECH USB Device: Device: "/dev/input/event1"
[  1217.654] (--) evdev: A4TECH USB Device: Vendor 0x9da Product 0x9090
[  1217.654] (--) evdev: A4TECH USB Device: Found 1 mouse buttons
[  1217.654] (--) evdev: A4TECH USB Device: Found scroll wheel(s)
[  1217.654] (--) evdev: A4TECH USB Device: Found relative axes
[  1217.654] (--) evdev: A4TECH USB Device: Found absolute axes
[  1217.654] (--) evdev: A4TECH USB Device: Found absolute multitouch axes
[  1217.654] (--) evdev: A4TECH USB Device: Fake MT device detected
[  1217.654] (--) evdev: A4TECH USB Device: Found x and y absolute axes
[  1217.654] (--) evdev: A4TECH USB Device: Found keys
[  1217.654] (II) evdev: A4TECH USB Device: Forcing relative x/y axes to exist.
[  1217.654] (II) evdev: A4TECH USB Device: Configuring as mouse
[  1217.654] (II) evdev: A4TECH USB Device: Configuring as keyboard
[  1217.654] (II) evdev: A4TECH USB Device: Adding scrollwheel support
[  1217.654] (**) evdev: A4TECH USB Device: YAxisMapping: buttons 4 and 5
[  1217.654] (**) evdev: A4TECH USB Device: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  1217.654] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.2/1-1.2:1.0/0003:09DA:9090.0001/input/input5/event1"
[  1217.654] (II) XINPUT: Adding extended input device "A4TECH USB Device" (type: KEYBOARD, id 10)
[  1217.654] (**) Option "xkb_rules" "evdev"
[  1217.654] (II) evdev: A4TECH USB Device: initialized for relative axes.
[  1217.654] (WW) evdev: A4TECH USB Device: ignoring absolute axes.
[  1217.654] (**) A4TECH USB Device: (accel) keeping acceleration scheme 1
[  1217.654] (**) A4TECH USB Device: (accel) acceleration profile 0
[  1217.654] (**) A4TECH USB Device: (accel) acceleration factor: 2.000
[  1217.654] (**) A4TECH USB Device: (accel) acceleration threshold: 4
[  1217.654] (II) config/udev: Adding input device A4TECH USB Device (/dev/input/js0)
[  1217.654] (II) No input driver specified, ignoring this device.
[  1217.654] (II) This device may have been added with another device file.
[  1217.655] (II) config/udev: Adding input device A4TECH USB Device (/dev/input/event2)
[  1217.655] (**) A4TECH USB Device: Applying InputClass "evdev pointer catchall"
[  1217.706] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 30 paused 0
[  1217.706] (II) Using input driver 'evdev' for 'A4TECH USB Device'
[  1217.706] (**) A4TECH USB Device: always reports core events
[  1217.706] (**) evdev: A4TECH USB Device: Device: "/dev/input/event2"
[  1217.707] (--) evdev: A4TECH USB Device: Vendor 0x9da Product 0x9090
[  1217.707] (--) evdev: A4TECH USB Device: Found 20 mouse buttons
[  1217.707] (--) evdev: A4TECH USB Device: Found scroll wheel(s)
[  1217.707] (--) evdev: A4TECH USB Device: Found relative axes
[  1217.707] (--) evdev: A4TECH USB Device: Found x and y relative axes
[  1217.707] (II) evdev: A4TECH USB Device: Configuring as mouse
[  1217.707] (II) evdev: A4TECH USB Device: Adding scrollwheel support
[  1217.707] (**) evdev: A4TECH USB Device: YAxisMapping: buttons 4 and 5
[  1217.707] (**) evdev: A4TECH USB Device: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  1217.707] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.2/1-1.2:1.1/0003:09DA:9090.0002/input/input6/event2"
[  1217.707] (II) XINPUT: Adding extended input device "A4TECH USB Device" (type: MOUSE, id 11)
[  1217.707] (II) evdev: A4TECH USB Device: initialized for relative axes.
[  1217.707] (**) A4TECH USB Device: (accel) keeping acceleration scheme 1
[  1217.707] (**) A4TECH USB Device: (accel) acceleration profile 0
[  1217.707] (**) A4TECH USB Device: (accel) acceleration factor: 2.000
[  1217.707] (**) A4TECH USB Device: (accel) acceleration threshold: 4
[  1217.707] (II) config/udev: Adding input device A4TECH USB Device (/dev/input/mouse0)
[  1217.707] (II) No input driver specified, ignoring this device.
[  1217.707] (II) This device may have been added with another device file.
[  1217.708] (II) config/udev: Adding input device USB2.0 HD UVC WebCam (/dev/input/event15)
[  1217.708] (**) USB2.0 HD UVC WebCam: Applying InputClass "evdev keyboard catchall"
[  1217.708] (II) systemd-logind: got fd for /dev/input/event15 13:79 fd 31 paused 0
[  1217.709] (II) Using input driver 'evdev' for 'USB2.0 HD UVC WebCam'
[  1217.709] (**) USB2.0 HD UVC WebCam: always reports core events
[  1217.709] (**) evdev: USB2.0 HD UVC WebCam: Device: "/dev/input/event15"
[  1217.709] (--) evdev: USB2.0 HD UVC WebCam: Vendor 0x4f2 Product 0xb40a
[  1217.709] (--) evdev: USB2.0 HD UVC WebCam: Found keys
[  1217.709] (II) evdev: USB2.0 HD UVC WebCam: Configuring as keyboard
[  1217.709] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.5/1-1.5:1.0/input/input22/event15"
[  1217.709] (II) XINPUT: Adding extended input device "USB2.0 HD UVC WebCam" (type: KEYBOARD, id 12)
[  1217.709] (**) Option "xkb_rules" "evdev"
[  1217.709] (II) config/udev: Adding input device Asus WMI hotkeys (/dev/input/event14)
[  1217.709] (**) Asus WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[  1217.710] (II) systemd-logind: got fd for /dev/input/event14 13:78 fd 32 paused 0
[  1217.710] (II) Using input driver 'evdev' for 'Asus WMI hotkeys'
[  1217.710] (**) Asus WMI hotkeys: always reports core events
[  1217.710] (**) evdev: Asus WMI hotkeys: Device: "/dev/input/event14"
[  1217.710] (--) evdev: Asus WMI hotkeys: Vendor 0 Product 0
[  1217.710] (--) evdev: Asus WMI hotkeys: Found keys
[  1217.710] (II) evdev: Asus WMI hotkeys: Configuring as keyboard
[  1217.710] (**) Option "config_info" "udev:/sys/devices/platform/asus-nb-wmi/input/input21/event14"
[  1217.710] (II) XINPUT: Adding extended input device "Asus WMI hotkeys" (type: KEYBOARD, id 13)
[  1217.710] (**) Option "xkb_rules" "evdev"
[  1217.710] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[  1217.710] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  1217.711] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 33 paused 0
[  1217.711] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[  1217.711] (**) AT Translated Set 2 keyboard: always reports core events
[  1217.711] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[  1217.711] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[  1217.711] (--) evdev: AT Translated Set 2 keyboard: Found keys
[  1217.711] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[  1217.711] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[  1217.711] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 14)
[  1217.711] (**) Option "xkb_rules" "evdev"
[  1217.711] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event13)
[  1217.711] (**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchpad catchall"
[  1217.711] (**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchscreen catchall"
[  1217.711] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[  1217.711] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
[  1217.711] (II) LoadModule: "synaptics"
[  1217.711] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[  1217.712] (II) Module synaptics: vendor="X.Org Foundation"
[  1217.712] compiled for 1.17.4, module version = 1.8.3
[  1217.712] Module class: X.Org XInput Driver
[  1217.712] ABI class: X.Org XInput driver, version 21.1
[  1217.712] (II) systemd-logind: got fd for /dev/input/event13 13:77 fd 34 paused 0
[  1217.712] (II) Using input driver 'synaptics' for 'ETPS/2 Elantech Touchpad'
[  1217.712] (**) ETPS/2 Elantech Touchpad: always reports core events
[  1217.712] (**) Option "Device" "/dev/input/event13"
[  1217.740] (II) synaptics: ETPS/2 Elantech Touchpad: found clickpad property
[  1217.740] (--) synaptics: ETPS/2 Elantech Touchpad: x-axis range 0 - 3249 (res 33)
[  1217.740] (--) synaptics: ETPS/2 Elantech Touchpad: y-axis range 0 - 2223 (res 33)
[  1217.740] (--) synaptics: ETPS/2 Elantech Touchpad: pressure range 0 - 255
[  1217.740] (--) synaptics: ETPS/2 Elantech Touchpad: finger width range 0 - 15
[  1217.740] (--) synaptics: ETPS/2 Elantech Touchpad: buttons: left double triple
[  1217.740] (--) synaptics: ETPS/2 Elantech Touchpad: Vendor 0x2 Product 0xe
[  1217.740] (**) Option "TapButton1" "1"
[  1217.740] (**) Option "TapButton2" "2"
[  1217.740] (**) Option "TapButton3" "3"
[  1217.740] (**) Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
[  1217.740] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[  1217.740] (**) ETPS/2 Elantech Touchpad: always reports core events
[  1217.740] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input17/event13"
[  1217.740] (II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD, id 15)
[  1217.740] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MinSpeed is now constant deceleration 2.5
[  1217.740] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MaxSpeed is now 1.75
[  1217.740] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) AccelFactor is now 0.051
[  1217.740] (**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
[  1217.740] (**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 1
[  1217.740] (**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
[  1217.740] (**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4
[  1217.740] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[  1217.741] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse1)
[  1217.741] (**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[  1222.166] (II) UnloadModule: "synaptics"
[  1222.166] (II) systemd-logind: releasing fd for 13:77
[  1222.196] (II) evdev: AT Translated Set 2 keyboard: Close
[  1222.196] (II) UnloadModule: "evdev"
[  1222.196] (II) systemd-logind: releasing fd for 13:64
[  1222.226] (II) evdev: Asus WMI hotkeys: Close
[  1222.226] (II) UnloadModule: "evdev"
[  1222.226] (II) systemd-logind: releasing fd for 13:78
[  1222.253] (II) evdev: USB2.0 HD UVC WebCam: Close
[  1222.253] (II) UnloadModule: "evdev"
[  1222.253] (II) systemd-logind: releasing fd for 13:79
[  1222.279] (II) evdev: A4TECH USB Device: Close
[  1222.280] (II) UnloadModule: "evdev"
[  1222.280] (II) systemd-logind: releasing fd for 13:66
[  1222.306] (II) evdev: A4TECH USB Device: Close
[  1222.306] (II) UnloadModule: "evdev"
[  1222.306] (II) systemd-logind: releasing fd for 13:65
[  1222.333] (II) evdev: Sleep Button: Close
[  1222.333] (II) UnloadModule: "evdev"
[  1222.333] (II) systemd-logind: releasing fd for 13:68
[  1222.366] (II) evdev: Video Bus: Close
[  1222.366] (II) UnloadModule: "evdev"
[  1222.366] (II) systemd-logind: releasing fd for 13:70
[  1222.393] (II) evdev: Video Bus: Close
[  1222.393] (II) UnloadModule: "evdev"
[  1222.393] (II) systemd-logind: releasing fd for 13:71
[  1222.426] (II) evdev: Power Button: Close
[  1222.426] (II) UnloadModule: "evdev"
[  1222.426] (II) systemd-logind: releasing fd for 13:69
[  1222.487] (II) NVIDIA(GPU-0): Deleting GPU-0
[  1222.775] (II) Server terminated successfully (0). Closing log file.

I tried uninstall bumblebee via mhwd, and install video-nvidia, but it wasnt working either. I tried edited nvidia.conf generated by mhwd to configuration as given here: https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia
And added two xrandr commands to my ~/.xinitrc, and tested startx. I get the black screen again. I believe that nvidia-xrun is doing the same as described in this archlinux wiki page.
I hope that someone can help me, fix the black screen issue i have.

EDIT1: in xrandr I found that nvidia is missing Source Output capability. I tried newest update today, same issue.
Code: [Select]
DISPLAY=:1 xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x1f0 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:NVIDIA-0
Provider 1: id: 0x45 cap: 0x2, Sink Output crtcs: 3 outputs: 3 associated providers: 0 name:modesetting
« Last Edit: 16. May 2016, 10:15:11 by Mutant22 »