Author Topic: Upgrade KDE 4 installation to Plasma 5  (Read 57744 times)

0 Members and 1 Guest are viewing this topic.

Offline AJ1000

  • Sr. Mitglied
  • ****
  • Posts: 443
  • Branch: stable
  • Desktop: LXQT
  • GPU Card: NVidia
  • GPU driver: Free
  • Skill: Novice
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #195 on: 22. November 2015, 12:29:21 »
The alternative is to wait until the fix for the bluez issue is put into the stable branch. I tried it in unstable and it works, so bluez does not need to be removed.

Offline leledumbo

  • Sr. Mitglied
  • ****
  • Posts: 371
    • Pascal Warrior's Journey
  • Branch: stable
  • Desktop: KDE
  • GPU Card: Intel HD 4400 + nVidia GeForce GT 740M (HP notebook), Intel HD 5500 + nVidia GeForce GT 940M (ASUS notebook), nVidia GeForce GT 220 (desktop)
  • GPU driver: non-free
  • Kernel: linux-latest-x64 and linux-latest LTS-x64
  • Skill: Intermediate
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #196 on: 04. December 2015, 20:54:29 »
Just had a successful upgrade. The instruction on first page is still applicable, including the "if that doesn't work" parts ;D
Manjaro Net edition 64-bit + Self installed KDE
Kernel latest supported + latest LTS
HP Pavilion 14-n038tx
Asus A455LB-WX034D
Self built desktop

Offline Rio

  • Jr. Mitglied
  • **
  • Posts: 66
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #197 on: 05. March 2016, 04:37:47 »
After upgrade, where did all the default Manjaro wallpapers go?

Offline Smellyman

  • Neuling
  • *
  • Posts: 32
  • Skill: Novice
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #198 on: 10. March 2016, 12:05:49 »
On Step 2 I get this

Code: [Select]
sudo pacman -R $(LANG=C pacman -Qi kdebase-workspace | grep "Req" | sed -e 's/Required By    : //g')
error: target not found: Required
error: target not found: By
error: target not found: :

Did syntax change?

EDIT:  Someone else used Octopi so I did too.  appeared to work.
« Last Edit: 10. March 2016, 13:51:01 by Smellyman »

Offline c00ter

  • Held Mitglied
  • *****
  • Posts: 1534
  • Towelie's cupcake
  • Branch: ☮Olive☮
  • Desktop: Depends©
  • GPU Card: Intel HD4400M CPU: Core i7-4510U
  • GPU driver: Intel/Free
  • Kernel: 4.4-lts & 4.5
  • Skill: Novice
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #199 on: 10. March 2016, 14:03:35 »
What I want to know, is anybody actually now upgrading a KDE4 installation to KDE5? Now, long after KDE4 has been removed from Arch base?  Or has this bumped thread just caused a bit of confusion..?
“What, me worry?” ― Alfred E. Newman

Manjaro Wiki: https://wiki.manjaro.org/
Arch Wiki: https://wiki.archlinux.org/
Pacman Rosetta: https://wiki.archlinux.org/index.php/Pacman/Rosetta

Offline Smellyman

  • Neuling
  • *
  • Posts: 32
  • Skill: Novice
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #200 on: 10. March 2016, 18:10:08 »
What I want to know, is anybody actually now upgrading a KDE4 installation to KDE5? Now, long after KDE4 has been removed from Arch base?  Or has this bumped thread just caused a bit of confusion..?

I was stubbornly waiting until Qt 5.6 was released on my production machine, but it kept being pushed back months.  Supposed to be released on the 16th....we'll see.  This last update finally had too many dependency issues so I just did the upgrade.  Worked well.

I had clean installs on 3 other machines.
« Last Edit: 10. March 2016, 18:13:36 by Smellyman »

Offline c00ter

  • Held Mitglied
  • *****
  • Posts: 1534
  • Towelie's cupcake
  • Branch: ☮Olive☮
  • Desktop: Depends©
  • GPU Card: Intel HD4400M CPU: Core i7-4510U
  • GPU driver: Intel/Free
  • Kernel: 4.4-lts & 4.5
  • Skill: Novice
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #201 on: 10. March 2016, 19:30:45 »
I was stubbornly waiting until Qt 5.6 was released on my production machine, but it kept being pushed back months.  Supposed to be released on the 16th....we'll see.  This last update finally had too many dependency issues so I just did the upgrade.  Worked well.

I had clean installs on 3 other machines.

Ah, so! I was wondering if there was anyone running servers, but with as many machines as yours it makes sense. I recently re-installed KDE after several years living in Gtk3-Land. Currently Qt 5.5.1-10 in vanilla Arch, so it should roll soon.

Regards
“What, me worry?” ― Alfred E. Newman

Manjaro Wiki: https://wiki.manjaro.org/
Arch Wiki: https://wiki.archlinux.org/
Pacman Rosetta: https://wiki.archlinux.org/index.php/Pacman/Rosetta

Offline leledumbo

  • Sr. Mitglied
  • ****
  • Posts: 371
    • Pascal Warrior's Journey
  • Branch: stable
  • Desktop: KDE
  • GPU Card: Intel HD 4400 + nVidia GeForce GT 740M (HP notebook), Intel HD 5500 + nVidia GeForce GT 940M (ASUS notebook), nVidia GeForce GT 220 (desktop)
  • GPU driver: non-free
  • Kernel: linux-latest-x64 and linux-latest LTS-x64
  • Skill: Intermediate
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #202 on: 11. March 2016, 14:01:40 »
On Step 2 I get this

Code: [Select]
sudo pacman -R $(LANG=C pacman -Qi kdebase-workspace | grep "Req" | sed -e 's/Required By    : //g')
error: target not found: Required
error: target not found: By
error: target not found: :

Did syntax change?
Nope, but "Required By" on my machine shows 5 space before ":" instead of 4. Better replace the sed substitute parameter to 's/Required By\s*:\s*//g' so it doesn't depend on any specific number of whitespace.
Manjaro Net edition 64-bit + Self installed KDE
Kernel latest supported + latest LTS
HP Pavilion 14-n038tx
Asus A455LB-WX034D
Self built desktop

Offline DrMartinus

  • Neuling
  • *
  • Posts: 2
  • I'm new. Be nice!
  • Skill: Novice
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #203 on: 03. April 2016, 17:18:41 »
To install Plasma 5 in a net installation, you would start in step 3.

1. Update your system
Code: [Select]
sudo pacman -Syu
2. Remove everything that depends on kdebase-workspace
Code: [Select]
sudo pacman -R $(LANG=C pacman -Qi kdebase-workspace | grep "Req" | sed -e 's/Required By    : //g')

I did step 1, but step 2 returned this error:

Code: [Select]
Fehler: Ziel nicht gefunden: Required
Fehler: Ziel nicht gefunden: By
Fehler: Ziel nicht gefunden: :

"Ziel nicht gefunden" means "target not found" - my system uses German, as I am German. For me it seems as if something is wrong with the syntax of th sed command, but I can't figure it out and it seems as if others have no such problem. Why me???

Edit: After having found that others had that problem, too, I discovered this marvellous suggestion:

Quote
"Required By" on my machine shows 5 space before ":" instead of 4. Better replace the sed substitute parameter to 's/Required By\s*:\s*//g' so it doesn't depend on any specific number of whitespace.
That helped, so I could upgrade now to Plasma 5.
« Last Edit: 03. April 2016, 17:50:19 by DrMartinus »

Offline Kirek

  • Core Team
  • *****
  • Posts: 1209
  • Branch: unstable
  • Desktop: Plasma 5
  • GPU Card: Intel HD4000 + Nvidia 620M / Geforxe GTX 970
  • GPU driver: nonfree
  • Kernel: Latest
  • Skill: Intermediate
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #204 on: 03. April 2016, 18:42:25 »
Thx, changed.