Author Topic: Upgrade KDE 4 installation to Plasma 5  (Read 57752 times)

0 Members and 1 Guest are viewing this topic.

Offline rydhwan

  • Sr. Mitglied
  • ****
  • Posts: 287
  • slowly
  • Branch: unstable
  • Desktop: Plasma 5, Gnome, Cinnamon, Deepin, Unity,
  • GPU Card: Intel
  • GPU driver: free driver
  • Kernel: linux 4.1
  • Skill: Novice
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #15 on: 30. November 2014, 21:23:44 »
nice and about dolphin  8)
American dream. welcome to Guantánamo civil-isation

we are all different ... this is our common

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #16 on: 30. November 2014, 21:40:55 »
Is this what your looking for?
Code: [Select]
yaourt -S dolphin-frameworks-git
Or would you rather have all the KDE frameworks base applications:
dolphin-frameworks-git
konqueror-frameworks-git
kdepasswd-frameworks-git
kdialog-frameworks-git
kfind-frameworks-git
keditbookmarks-frameworks-git
libkonq-frameworks-git

To install these all at once:
Code: [Select]
yaourt -S kde-baseapps-git
« Last Edit: 30. November 2014, 21:47:57 by AJSlye »

Offline rydhwan

  • Sr. Mitglied
  • ****
  • Posts: 287
  • slowly
  • Branch: unstable
  • Desktop: Plasma 5, Gnome, Cinnamon, Deepin, Unity,
  • GPU Card: Intel
  • GPU driver: free driver
  • Kernel: linux 4.1
  • Skill: Novice
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #17 on: 30. November 2014, 22:21:06 »
thanks AJSlye  8)

when install whith octopi i have

There are no means to get administrator's credentials.
You'll need to install a su frontend like gksu or kdesu.
but kdesu is installed
« Last Edit: 30. November 2014, 22:28:34 by rydhwan »
American dream. welcome to Guantánamo civil-isation

we are all different ... this is our common

Offline rydhwan

  • Sr. Mitglied
  • ****
  • Posts: 287
  • slowly
  • Branch: unstable
  • Desktop: Plasma 5, Gnome, Cinnamon, Deepin, Unity,
  • GPU Card: Intel
  • GPU driver: free driver
  • Kernel: linux 4.1
  • Skill: Novice
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #18 on: 30. November 2014, 22:32:12 »
yaourt -S kde-baseapps-git
[sudo] password for rydma:
error: target not found: kde-baseapps-git
American dream. welcome to Guantánamo civil-isation

we are all different ... this is our common

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #19 on: 30. November 2014, 22:32:53 »
I just checked and it is in there: https://aur.archlinux.org/pkgbase/kde-baseapps-git/

OK, to use octopi in plasma 5 you'll need to remove octopi / octopi-notifier and install the frameworks version from the AUR in a terminal:
Code: [Select]
yaourt -S octopi-frameworks-git
@Kirek

Maybe you should rewrite this temporary tutorial and put in there how to add the kf5apps repository because a lot of what is needed for a completely working plasma 5 desktop is in there?
« Last Edit: 30. November 2014, 22:38:51 by AJSlye »

Offline Kirek

  • Core Team
  • *****
  • Posts: 1209
  • Branch: unstable
  • Desktop: Plasma 5
  • GPU Card: Intel HD4000 + Nvidia 620M / Geforxe GTX 970
  • GPU driver: nonfree
  • Kernel: Latest
  • Skill: Intermediate
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #20 on: 30. November 2014, 22:36:45 »
octopi in the repos its already compiled against qt5, and we also provide both frameworks and normal version of octopi notifier: octopi-notifier and octopi-notifier-frameworks

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #21 on: 30. November 2014, 22:39:38 »
octopi-frameworks-git is not the same as the QT5 compiled version in the repositories.

Offline Kirek

  • Core Team
  • *****
  • Posts: 1209
  • Branch: unstable
  • Desktop: Plasma 5
  • GPU Card: Intel HD4000 + Nvidia 620M / Geforxe GTX 970
  • GPU driver: nonfree
  • Kernel: Latest
  • Skill: Intermediate
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #22 on: 30. November 2014, 22:43:34 »
octopi-frameworks-git it's the same, the difference (excluding its git), is that they include octopi-notifier in the same package, and we provide the notifier in a separate package.
The octopi-notifier-frameworks its build exactly as the octopi nofier in octopi-frameworks-git

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #23 on: 30. November 2014, 23:06:13 »
OK, let me break this down for you, as the version of octopi in repository doesn't work with kdesu 5.x.x:

In the Manjaro stable repository is:
octopi  4.2.1-1
octopi-notifier 4.2.1-1

in Manjaro testing and unstable:
octopi-0.5.0-2
octopi-notifier-0.5.0-2
and
octopi-notifier-frameworks-0.5.0-2

Now in the AUR:
octopi  0.5.0-1
octopi-notifier 0.5.0-1
octopi-repoeditor 0.5.0-1
octopi-notifier-foundations 0.5.0-1
and
octopi-git 20141030.dfdefa2-1
octopi-frameworks-git 0.5.0_692.349b8e5-1



Offline Kirek

  • Core Team
  • *****
  • Posts: 1209
  • Branch: unstable
  • Desktop: Plasma 5
  • GPU Card: Intel HD4000 + Nvidia 620M / Geforxe GTX 970
  • GPU driver: nonfree
  • Kernel: Latest
  • Skill: Intermediate
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #24 on: 30. November 2014, 23:17:53 »
Quote
octopi-0.5.0-2
octopi-notifier-0.5.0-2
and
octopi-notifier-frameworks-0.5.0-2

This is not working with kdesu 5?

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #25 on: 30. November 2014, 23:21:05 »
Nope the expect the kdesu version from KDE SC 4.x.x.

Offline Kirek

  • Core Team
  • *****
  • Posts: 1209
  • Branch: unstable
  • Desktop: Plasma 5
  • GPU Card: Intel HD4000 + Nvidia 620M / Geforxe GTX 970
  • GPU driver: nonfree
  • Kernel: Latest
  • Skill: Intermediate
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #26 on: 30. November 2014, 23:37:50 »
An it works with octopi-frameworks-git ? I'm surprised, its built exactly as our octopi package + octopi-notifier-frameworks, no changes, and no git commit to support the binary kde-cli-tools puts in /usr/lib/kdesu either.

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #27 on: 01. December 2014, 01:23:02 »
My apologies, I was referring to the ones in stable, I haven't tried the ones in testing/unstable, if those are what is installed on the Manjaro 0.9.0 Plasma 5 ISO's then you may be right.

Offline Kirek

  • Core Team
  • *****
  • Posts: 1209
  • Branch: unstable
  • Desktop: Plasma 5
  • GPU Card: Intel HD4000 + Nvidia 620M / Geforxe GTX 970
  • GPU driver: nonfree
  • Kernel: Latest
  • Skill: Intermediate
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #28 on: 01. December 2014, 01:47:42 »
Ah yes if its stable octopi is still qt4 and the notifier doesnt work at all in plasma 5.

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: Upgrade KDE 4 installation to Plasma 5
« Reply #29 on: 01. December 2014, 01:56:55 »
OK, now I have some questions:

Why these three files:
octopi 0.5.0-2
octopi-notifier 0.5.0-2
octopi-notifier-frameworks 0.5.0-2

and not these three:
octopi 0.5.0-x
octopi-notifier 0.5.0-x
octopi-repoeditor 0.5.0-x

Does this mean that there is no repository editor for octopi in testing and unstable?

And what's the difference between octopi-notifier-frameworks and octopi-notifier in those repositories?
« Last Edit: 01. December 2014, 02:01:35 by AJSlye »